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1 Introduction 

1.1 TRNSYS 18 Background 

TRNSYS is a complete, modular, and expansible simulation environment for the transient simulation of thermal 
systems including multi-zone buildings. It is used by engineers and researchers around the world to validate new 
energy concepts, from simple solar domestic hot water systems to the design and simulation of buildings and their 
equipment, including control strategies, occupant behavior, alternative energy systems (wind, solar, photovoltaic, 
hydrogen systems), etc.  

One of the key factors in TRNSYS’ success over the last 30 years is its open, modular structure. The source code 
of the kernel as well as the component models is delivered to the users. This simplifies extending existing models 
to make them fit the user’s specific needs.  

The DLL-based architecture allows users and third-party developers to easily add custom component models, 
using all common programming languages (Python, C, C++, PASCAL, FORTRAN, etc.). In addition, TRNSYS can 
be easily connected to many other applications, for pre- or post-processing or through interactive calls during the 
simulation (e.g. Microsoft Excel, Matlab, etc.). TRNSYS applications include: 

▪ Solar systems (solar thermal and PV) 
▪ Low energy buildings and HVAC systems with advanced design features (natural ventilation, slab 

heating/cooling, double façade, etc.) 
▪ Renewable energy systems 
▪ Cogeneration, fuel cells 
▪ Anything that requires dynamic simulation! 

If TRNSYS is used in building design, the multi-zone building model, so-called Type56 is the most important 
component with integrated models for thermoactivated components and daylight simulation, among other things. 
In contrast to other components, the building model requires a much more comprehensive and different data set 
for each building, which contains the entire building description including the time-dependent operation mode. The 
main interface for creating the building description is called TRNBuild. For more information see the building 
model manual (\TRNSYS18\Documentation\05-MultizoneBuilding.pdf). 

1.2 Trnsys3d Plug-in 

To easily generate the geometric information for the building model of TRNSYS (Type 56), the plug-in Trnsys3d 
for Goggle SketchUp™ has been developed. It allows the user draw the building as well as shading geometry. 
This means you should have the thermal zoning defined before you start.   

This information can be imported in TRNBuild. Note that the plug-in is not a full-featured interface. Non-geometric 
data, such as materials, controls, internal heat gains, HVAC equipment and systems, etc. are defined in 
TRNBuild.  

The Trnsys3d plug-in is based on the open source legacy plugin of OpenStudio™ 
(https://github.com/NREL/legacy-openstudio). Therefore, it can’t be integrated into the TRNSYS package but is 
available for free download under GNU-GPL.  

1.3 New Developments 

New features for the current Trnsys3d version 1.0.7.1 are listed below: 

▪ Simulation Studio Wizard for Trnsys3d 
▪ Zone templates (generic zone types) for Trnsys3d 
▪ Daylight Controls in Trnsys18 
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2 Create 3D model with Trnsys3d in SketchUp 

2.1 Installation of SketchUp and Trnsys3d Plug-in 

• Download and install Google SketchUp from http://sketchup.google.com/. 

• The installer of Trnsys3d is included in the TRNSYS 18 package ( \TRNSYS18\Tools\T3d_setup.exe). In 
general, the installer is started as Add-on after the TRNSYS 18 installation. If this isn’t the case, install 
trnsys3d manually by executing the T3d_setup.exe. A download link is provided at 
https://www.trnsys.de/en/addons-en 

• Start Google Sketchup. If you are starting Google SketchUp for the first time, you will be prompted to choose 
a Google SketchUp template. Choose the ‘Engineering – Meters’ template and click ‘Start using SketchUp’.  

• If you already use SketchUp in IP units, it is recommended that you switch to ‘Engineering – Meters’ 
Template.  To do this, go to Window > Preferences > Template >  ‘Engineering – Meters’  
 

 

• Delete the drawing of the person standing at the axis origin by clicking on it and pressing ‘Delete’  

  

http://sketchup.google.com/
https://www.trnsys.de/en/addons-en
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2.2 Understanding “Zones” – SketchUp Zones vs.Trnsys3d zones 

2.2.1 SketchUp Zones 

 
In SketchUp, the interior walls make up the zones. For example, in the building pictured above, there are no 
interior walls, so it is modelled as one large rectangular zone.  Note that the smaller cube represents an exterior 
shade and is not a zone. 

2.2.2 Trnsys3d Zones  

 
Trnsys3d zones are different from SketchUp zones, particularly because Trnsys3d zones are used to simulate the 
dynamic flow of energy. An energy model of a building should typically be separated into perimeter and core 
zones. This is important to separate the effects of infiltration from the perimeter and core, and to correctly account 
for solar gains into the building.  

Trnsys3d zones are restricted to have one airnode associated to it. For special spaces like atria, it may make 
sense to model a zone with multiple airnodes (see Chapter Frequently Asked Questions FAQ - Atrium and Virtual 
Surfaces for more details). 

 

   
  

convex concaveconvex concave

 

It is important to note, that for applying 
the detailed interior radiation models 
(solar radiation distribution and/or 
interior longwave radiation exchange) 
zones have to be convex volumes.  

This means that every surface in the 
zone should be in the line of sight with 
all other surfaces of the zone. (no 
obstructed views) 

! 



Trnsys3d Tutorial 

6 

 

2.3 Build a single-zone model in Trnsys3d 

To use the plug-in as intended, you must have the energy model in mind (NOT the architectural model) from the 
beginning as you create your SketchUp model.   

2.3.1 Automatic Prompt to select pre-made zone template 

Upon launching Google SketchUp after the Trnsys3d plugin has been installed, you will be prompted to choose a 
template for your 3D model. This template contains pre-defined information for your *.b18 file for schedules, 
heating, cooling, ventilation, infiltration, internal gains and daylight. If you don’t want to use a predefined template, 
choose NewFileTemplate.idf. 

Choose German > 1_apartment_basedon_SIA2024.idf and click Open. 

For the German library, these zone templates according to SIA 2024 are available: 

1. Apartment 

• Living/bedroom 

• kitchen 
2. hotel 

• hotel room 

• reception 
3. office 

• office 

• office 

• meeting 

• reception 
4. School 

• classroom 

• staffroom 

• library 

• lecturehall 

• specialroom 
5. Supermarket 

• commercial 
6. Restaurant 

• restaurant 

• kitchen 
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2.3.2 Create a Trnsys3d Zone 

Create a new Trnsys3d zone by choosing Plugins > Trnsys3d > New Zone Tool  from the main menu. A 
small, blue cross-hair will appear at the tip of the cursor arrow. Hover over the axis origin until a small yellow dot 
appears and click. This will place a blue box on the screen, which represents the Trnsys3d zone. If the blue box is 
not visible, try changing the view to fit the object by going to Camera > Zoom Extents from the main SketchUp 
menu. Now you can zoom in and out with the mouse wheel to fit the object in the window as desired.  

 

 

Note that by clicking on the screen outside of the blue box, the object 
will disappear from view. This is normal. Turn on hidden geometry (Go 
to View > Hidden Geometry from the main menu) and a small gray 
cross‐hair will be visible at the opposite corner of the box.  

                                     

This cross hair allows the user to find the Trnsys3d zone more easily. Note that if you click on the gray cross‐hair, 
the Trnsys3d zone is outlined in blue again.  

Double click on the small cross‐hair, which is now visible with hidden geometry turned on. The blue outline of the 
Trnsys3d zone should be replaced with a slightly larger box with a broken, black outline. This ‘activates’ the 
Trnsys3d zone. Note that in order to modify the Trnsys3d geometry the Trnsys3d zone MUST be ‘activated’ 
(outlined with the broken black line). Alternative to clicking on the crosshair, double click inside the blue box. 

 

NORTH 

EAST 

SKY 
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2.3.3 Modifying Geometry within the Trnsys3d zone 

Make sure that the Trnsys3d zone is still ‘active’ (outlined with the broken black line). Then create the floor for the 

model by going to Draw ‐> Rectangle  from the main menu. Start the rectangle at the axis origin by clicking on 
the origin. Next designate the size of the rectangle by typing ’12, 4’ and pressing enter (you can see the numbers 
being input in the lower right hand corner of the screen, the comma between the numbers is operating system 
language dependent and can also be ;,.). This will create a 12m by 4m floor.  

 

 

 

 

 

Next ‘pull’ the rectangle up to create a rectangular prism. Make sure that the Trnsys3d zone is still ‘active’ 
(outlined with the broken black line). Choose Tools > Push/Pull from the main menu. Hover over the rectangle 
until small blue dots appear on the floor surface and click ONCE with the mouse. The tool will ‘grab’ the rectangle 
surface. Move the mouse up and down to see how the tool works. Move the mouse slightly up (so that the 
rectangle is projecting towards the top of the screen), type ‘4’, and press enter. This will ‘pull’ the rectangle up to 
create a 4m tall prism.  

Note the gray color of the floor. This color is automatically generated by 
Trnsys3d and designates this surface as a floor in Trnsys3d. Similarly, 
the walls and roof will be colored accordingly, in the next few steps. ! 

This is what separates the Trnsys3d 
geometry from SketchUp geometry. 
Any object drawn in a ‘unactivated’ 
Trnsys3d zone is only SketchUp 
geometry and will not be written out 
to the Trnsys3d IDF file. It is VERY 
important to make sure the zone is 
activated before you start creating 
geometry. 

 

 

 ! 

This is what separates the Trnsys3d 
geometry from SketchUp geometry. Any 
object drawn in a ‘non activated’ Trnsys3d 
zone is only SketchUp geometry and will 
not be written out to the Trnsys3d IDF file.  

It is VERY important to make sure the 
zone is activated before you start creating 
geometry 
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2.3.4 Creating fenestration objects 

Trnsys3d can also be used to generate fenestration objects. Make sure that your Trnsys3d zone is still ‘active’ 
(outlined with the broken black line).  Use the tape measure tool to create a 1m offset guides from the corner of 

the wall.  Select Tools > Tape Measure  and click once on the lower right-hand corner.  Hover to a point above 
the corner, type in ‘1’ and press enter.  A small black crosshair will appear.  Using the tape measure tool again, 
click once on the new crosshair and hover to a point left of it, type in ‘1’ and press enter.  A dotted vert ical guide 
and another crosshair will now appear on the wall surface. 

 

Now, select Draw > Rectangle and click once on the crosshair located on the wall surface.  Type in ‘6,2’ and 
press enter.  Note that as long as the rectangle is completely contained within the wall surface, Trnsys3d will 
recognize it as a window and automatically color it a transparent blue. A skylight is created the same way as a 

Saving the IDF File  
It is crucial to save the IDF file early and often. The IDF file is separate 
from the SketchUp file and saving the SketchUp file will not preserve the 
IDF information. To save the IDF file, choose Plugins > Trnsys3d > Save 

from the main menu . If it is the first time you are saving the file a dialog 
box will prompt you for a location and name.  

! 
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window, but the rectangle is drawn on a roof instead of a wall. The guidelines can be removed by going to Edit > 
Delete Guides. This will also remove the hidden geometry. 

 

 

2.3.5 Create external shading objects 

Trnsys3d can be used to create shading objects, including overhangs and detached shading objects to represent 

other buildings. Select Plugins > Trnsys3d > New Shading Group Tool , which is very similar to the new zone 
tool. For this example, place the new shading group at the axis origin. Just like the new zone tool, in order to edit 
the shading group geometry you must make the group ‘active’. To do this, press enter while the shading group 
geometry is highlighted blue, or double click on the small gray cross‐hair that was created when you placed the 
new shading group. When the shading group is ‘active’ you should see the rest of the model become lighter.  

 

 

 

Use the rectangle tool to create the footprint of a detached shading object.  Click the origin once and move the 
mouse so that the footprint is previewed in the correct quadrant. Type in ‘4,4’, which will create a floor surface of 
4m by 4m. (Attention: if your language settings are using “,” as the decimal separator, you will have to type “4;4” 
instead.) Notice that the grey dotted box extends itself to include the floor surface.   
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Similar to creating a new zone, use the Push/Pull tool  to ‘pull’ the shading surface up to 4m.   

 

 

2.3.6 Using the Outliner Window 

We will now use the outliner window to review the zones that we have created. To access the outliner window 

from the main menu choose Window > Outliner : 

 

You can use the outliner window to select the Trnsys3d objects by clicking on them. Double clicking on an object 
in the outliner window will ‘activate’ the object. You should have one Trnsys3d shading group and one Trnsys3d 
zone with a random six‐digit alphanumeric name. If you have any additional objects placed on accident select 
them in the outliner window and delete them.  

2.3.7 Using the Object Info Tool 

Trnsys3d also has the ability to modify the Trnsys3d object information. Choose Plugins > Trnsys3d > Object Info 

. The class type will change as objects are selected on the screen. If nothing is selected, the class type is 
‘Building’. Change the name of the building to ‘TRNSYS18’ 
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Click on the zone in the main SketchUp drawing area and you will see the class type change to ‘Zone’ in the 
object info window. Change the Zone name from the default six-digit alphanumeric zone name to ‘First_Floor’ 
(!!!NOTE: No Spaces!!!) and press TAB on your keyboard to confirm. Select the Zone Type template 
‘11livingbedroom’ from the drop-down for ‘Type’. 
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Open the outliner window again; notice that the Trnsys3d zone name has changed.  

 

 

 

 

 

 

 

 

 

With the object info window still open double click on ‘First Floor’ in the 
SketchUp model to ‘activate’ the zone. Notice how the object info changes as 
you select a wall, roof, or window (note characteristics like surface name, type, 
construction, zone, outside boundary conditions, and the ground view factor). 
You can change the surface type, the construction, and outside boundary 
condition for each surface. Toggle between surfaces by clicking on them on the 
main SketchUp window.  You cannot change the surface name, as it will be 
automatically changed later on. 

! 
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2.3.8 Movable shading for windows 

Windows in TRNSYS 18 can have an automatic internal shading calculation depending to user-defined set points. 
For this reason in the Object Info of Trnsys3d for windows there is a new drop down called shading device. Here 
one can define if the window will have an internal or external shading device. The set points can later on be 
adapted in the TRNBUILD window type manager.  
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2.3.9 User-defined wall constructions 

The option to define a new construction can be accessed through the SketchUp menu > Plugins > Trnsys3d > 
New Construction. This allows defining user-specific names for constructions that can be afterwards selected by 
the Object Info Window. The detailed wall construction including the layers and their thicknesses will have to be 
done after the import in TRNBUILD. 

 

2.3.10 User-defined Boundary Temperatures 

The option to define a new boundary temperature control can be accessed through the SketchUp menu > Plugins 
> Trnsys3d > New Boundary Temperature Control. This allows defining user-specific INPUT variables for a 
boundary temperature that can be afterwards selected by the Object Info Window. Make sure to change the 
Construction to ‘BND_WALL’, Outside Boundary Condition to ‘Other Side Coefficients’, and Outside Boundary 
Object to ‘BOUNDARY=INPUT 1* CORRIDOR’. 
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2.4 Add a second zone in Trnsys3d 

Create the second floor of the example model by creating a new Trnsys3d zone and repeating the previous steps, 
but ‘pull’ this floor to 5m instead of 4m.  To create a sloped roof, portions of the rectangular prism will be ‘sliced’ 
off.  Using the tape measure tool, place a crosshair guide 1m below the upper corner, as shown below.  Then 

select Draw > Line  and draw a line from the crosshair to the midpoint of the top edge. (The midpoint shows up 
in blue when you hover over it.) Draw another line connecting the midpoint to the edge opposite of the one with 
the crosshair, outlining the shape of the sloped roof. 

 

Select Tools > Push/Pull, hover over a triangle until the blue dots appear and click once inside the triangle.  Move 
the mouse towards the other end of the prism until the cut follows through the entire length of the prism and click 
to complete the ‘slicing’ (the cursor will snap to a triangle at the other end.)  Repeat for the other triangle.  

         

Note that the sloped roof you just created is now the same color as the walls.  To re-assign the surface type in 
Trnsys3d, right-click on the surface make the selections as shown below to finally choose ‘Roof’ for each sloped 
surface.  Repeat previous steps to rename this zone as “Second Floor” 
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Finally, the interzonal adjacencies must be considered.  The mating surfaces between the First Floor and Second 
Floor must be linked together.  Open Window > Outliner, and right click on the Second Floor to ‘Hide’ it.  If View > 

Hidden Geometry  is checked, then the second floor will appear hatched.  You must uncheck it to hide it. 

 

Next, double click the First Floor zone to ‘activate’ it.  Right Click on the roof of the first zone and select Trnsys3d 
> Object Info. Change the Type to “Ceiling” and construction to “ADJ_CEILING”. The outside boundary condition 
should be “Zone” and the outside boundary object is “Second Floor.” 

 

Right click on the Second Floor in the Outliner to unhide it.  Repeat the same steps above to hide the First Floor 
and reassign the floor of the Second Floor correctly. See the Object Info entries below.  Note that although the 
type of the Second floor is ‘Floor’, the construction must match the First Floor (ADJ_CEILING).  This is critical for 
adjacency recognition, when importing into TRNBUILD.  
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2.4.1 Matching Surfaces 

A method for automatic surfaces matching can be accessed through the SketchUp Trnsys3d menu toolbar. Click 

on the surface matching icon  to start matching walls, roofs and floors. A window will pop up that gives you 
different options like matching/unmatching surfaces or also to show the last reported matching information.  

 

Depending on the size of the models and the select geometry for matching surfaces this can be a slow process. 
Note that this method requires several key assumptions.   

First, in order to match two surfaces the methods requires that they both have same number of vertices and that 
the vertices exactly line up.  This can most easily be accomplished using the snap functionality of the SketchUp 
drawing tool.   

Secondly, construction names of the matched surfaces will be changed to (for each corresponding surface or sub 
surface type):  "ADJ_CEILING" and "ADJ_WALL" if construction objects of those names appear in the current idf 
file.  If construction objects with the assumed names are not found, then the construction of the matched surface 
will not be changed. 

 

  

Surface TYPE definition: VirtualSurface  

Note that the surface type definition “VirtualSurface” is a special one which 
is designed to be used for generating a zone with multiple airnodes. It is 
NOT representing a heat transfer surface in the building model. 

See Chapter Useful Tips/ Frequently Asked Questions FAQ - 
 

Atrium and Virtual Surfaces for more details. 

! 
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3 Import 3D geometry into Trnsys Simulation studio and TrnBuild 

3.1 Import IDF File into Simulation Studio with the Wizard 

The TRNSYS18 Simulation Studio offers the opportunity to automatically set up a simulation by importing the *.idf 
file with the 3D-Building Wizard. After opening the Simulation Studio, select ‘New Project’ in the menu and the 3D-
Building Project Wizard can be chosen. The Wizard prompts you for the location of your *.idf file, the location of 
the weather data file, (Note: The wizard requires a *.tm2 data format, you can change the reader and assign a 
different weather file of any other format later on) the building rotation, the static distribution factor of solar direct 
radiation (typical range from 0.6-0.8), shading controls for exterior shades and boundary temperatures of the 
ground and any adjacent spaces.   

A great advantage of the 3D-Building Wizard is that all orientations of the Building are linked automatically. This 
reduces errors and time used to link this information manually. 

 

The main reason for importing the 3D geometry into Simulation Studio is to use the Studio Wizard to generate the 
*.b18 and *.tpf files, which happens after you create the project with the Wizard.  The*.dck is generated when you 
click Calculate > Create Input File. The inputs for the model in Simulation studio are populated with information 
from the IDF template that was selected during the launch of SketchUp. 
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Select File > Save to save the Studio project. 

The Wizard creates a 3D model with default settings which can be found under “Wizard Settings”.  Double click 
the Wizard Settings icon to see input variables. Double click each input variable to see default assignments. It is 
possible, for example, to adjust the control for SHADE_CLOSE, directly in the circled cell below. 

For ground-adjacent models, it is important to define ‘t_T_min’, as highlighted in the image to the right, below.  
This variable equals the ‘coldest day’, in this example, 28 days from the start of the new year. Identify the coldest 
day for your climate and adjust t_T_min as necessary. 

 

For a first run, click Calculate > Run Simulation, which will launch Trnsys18 and by default it will run for a single 
week. Trnsys18 will prompt you to “Exit the Online Plotter” upon completion of the simulation.  Click “No” for the 
purposes of this tutorial. 
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By default there are 4 tabs along the bottom of the Online Plotter, showing outputs for solar radiation, 
temperatures, heating and cooling power, and electricity consumption of interior loads. Hold down shift and hover 
mouse in plotter area to see instantaneous values.  User-defined outputs can be added, see next sections. 

The directory where the Studio file is saved should now be populated with *.b18 and *.dck files. 

3.2 Import IDF File directly into TRNBuild 

It is also possible to import 3D geometry into TRNBuild, however this approach only generates the *.b18 file and 
is only appropriate when you have an existing *.dck file. This alternative workflow where the *.dck file is created 
from scratch, is not covered in this tutorial. See the part 9 of the TRNSYS Documentation for details on this.  

3.3 Further Information 

For further information on how to add further data such as materials, controls, internal heat gains, HVAC 
equipment and systems, etc. using TRNBuild and run simulations, please see the TRNSYS Tutorials at 
c:\TRNSYS18\Documentation\09-Tutorials.pdf (Chapter 9.3.2.4. Step 3 - Modification of the building description 
(TRNBuild)) and the building model manual c:\TRNSYS18\Documentation\05-MultizoneBuilding.pdf. 

  

file:///c:/TRNSYS18/Documentation/09-Tutorials.pdf
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4 Viewing Results in Trnsys3d 

Trnsys3d can be used to view Trnsys3d results. But first, the Trnsys3d requires results to be printed from the 
Trnsys3d Printer (Type 125), which is retrieved from the Direct Access Toolbar in the TRNSYS Simulation Studio.  

  

 
 

The Trnsys3d Printer will generate *.eso files that can be read by the Trnsys3d plugin to visualize results. The 
Trnsys3d printer can be configured in two different ways. 

1) The SurfacesID’s (corresponding to the ID’s in TRNBUILD) are required as initial values.  

     

 

2) The airnode names (corresponding to the names in TRNBUILD but with CAPITAL LETTERS!) are required as 
initial value. Initial value has to be defined as variable name.  

         

The information from the surfaces and airnodes can now be linked to Type125.  
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After linking the surfaces or airnodes outputs, it is recommended to open the building model in TRNBuild by 
selecting “Edit Building” and export the model as a Trnsys3d file ***_B18.idf to ensure that all changes made in 
TRNBuild are included. The ***_B18.idf model can be reloaded into Trnsys3d. First, go to the main SketchUp 

menu and chose Plugins > Trnsys3d > Renderings > Settings . This will open the rendering settings dialog box.  

 

Set the data path by browsing to the directory where you saved your IDF file. There should now be an ESO file 
generated by the Simulation Studio during the simulation. Choose the ESO file for the data path. The run period 
will automatically be filled once the ESO file is selected. Set the rest of the Rendering settings as shown above 
and click ‘OK’. The dialog box will close and nothing will appear to change. We now need to set Trnsys3d to 
render by data value instead of by surface class. To do this go to the main SketchUp menu and chose Plugins > 

Trnsys3d > Renderings > By Data Value . 

If any portion of model appears white, it indicates that no data results are available from the TRNSYS simulation 
for the selected date for that zone. The model should be coloured based on the airnode air temperature, as 
shown below. 

! 
Because the information in the data file will be interpreted by SketchUp and 
laid over the wire frame model of the building it is important that you include 
only one kind of output information (so-called NTYPE) in each file produced 
by Type125. Thus, one instance of Type125 might be used to print air 
temperatures, another one for heating loads and a third for surface 
temperatures. 

Do not, however include data for both temperature and relative humidity in 
the same instance of Type125. 
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Try matching the simulation run period in Trnsys3d with the Trnsys Simulation Studio results by setting it to the 
first week of January. In the SketchUp main menu, choose Plugins > Trnsys3d > Animation > Settings. This will 
open the Animation Settings dialog box. 

 
 

Check the ‘Match simulation run period’ and the ‘Repeat when finished’ checkboxes as shown above and hit ‘OK’. 
Lastly we need to reset the time to the beginning of the run period. In the SketchUp main menu, chose Plugins > 
Trnsys3d ‐> Animation ‐> Reverse to Marker. Make sure that the bottom left corner of the screen indicates 
January 01. If it says January 08, choose Plugins > Trnsys3d > Animation > Reverse to Marker again. Now the 
bottom left corner of the screen should say January 01. Also, turn on shadows to see the position of the sun by 
going to View ‐> Shadows from the main SketchUp Window. Note for displaying shadows correctly, the time zone 
has to be set to building location. (The geo-location of your model can be set in Window > Model Info > geo-
location) 
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Now that we have reset the time and have shadows on, we are finally ready to view the animation. To begin the 
animations go to the SketchUp main menu and chose Plugins > Trnsys3d > Animation > Play. At the bottom left 
of the screen you will see the time and date as the animation progresses. Notice that the zones are all slightly 
different colors, meaning that their temperature is different because of their construction, occupation,…..  

While the simulation is running we can view the temperature scale by going to the main SketchUp menu and 

chose Plugins > Trnsys3d > Renderings > Color Scale . Stop the animation the same way you started it, by 

going to the SketchUp main menu and chose Plugins > Trnsys3d > Animation > Play . Once the date passes 
the end of our run period the model will turn white because there is no data for it to display. The animation can 
begin from the beginning by first halting playback by going to the SketchUp main menu and choose Plugins > 
Trnsys3d > Animation > Play and then resetting the time by going to the SketchUp main menu and chose 
Plugins > Trnsys3d > Animation > Reverse to Marker. 
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5 Useful Tips/ Frequently Asked Questions FAQ 

5.1 General 

• Read the SketchUp documentation. 

• Check that unit settings are set to “High” accuracy    

  

• You may encounter difficulties using directories with “ä”, “ö”, “ü”, blanks etc. 

• To position vertices with precision or create surfaces with exact dimensions, use the Measurements in the 
lower right corner or use construction lines.  

 

• To draw quickly and accurately, use SketchUp’s snapping capabilities.  For example, to match the x-, y-, or z-
position of the endpoint of a line, hover the cursor over the endpoint until the tooltip appears. Click ONCE.  As 
you move the mouse, SketchUp will let you know when you are parallel to the reference line.  To lock a 
snapping function along an axis, hold down the shift key while you draw, and the line will appear bold and in 
the same color as the parallel axis.  
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5.2 Surfaces 

• In Trnsys3d, all building surfaces (walls, floors, etc.) are represented in 3-D coordinates as infinitesimally thin.  
Zone volume and surface area, which are automatically calculated entities, are derived from those 3-D 
coordinates.  However, you may modify the volume within TRNbuild. 

• The construction that you select for each surface determines the thickness for the purposes of the heat 
transfer calculation, but it does not affect any geometric considerations. 

• Typically, the building surfaces are measured from the outside edge of exterior walls, and the centerline for 
adjacent walls.  At the building corners, measuring from the outside edge will overestimate the total mass of 
the walls, while measuring from the inside edge will underestimate it. It is easier to measure the outside edge 
from the blueprints, but measuring from the centerline is the more accurate approach.  If the walls are 
especially thick, consider measuring from the centerline of the exterior walls.   

• The y-Axis is pointing north. There is no way to change this. 

• To add surfaces to a zone, the zone must be ‘activated’ by double clicking the blue outline.  An activated zone 
will be outlined in a grey dotted line. 

• Surfaces have to be drawn with an outward-pointing normal vector! Occasionally when you draw a surface, 
SketchUp will guess the wrong side to face out. You can tell because the side facing inside is a lighter color 
than the side facing outside. To correct this, use the SketchUp command Edit > Face > Reverse Faces. 

• Note that even if you rename your surfaces, they will be replaced with the surface IDs that are generated 
automatically when importing into TRNBuild. 

• Check and set the correct “Type” of all adjacent surfaces (Wall, Floor, Roof, Ceiling). 

• Select a “construction” for each surface. Otherwise the surface cannot be imported into TRNBuild correctly. 
The constructions can be modified within TRNBuild later. 

• This shows the translation of  “Outside Boundary Conditions” into TRNBuild syntax:  
Outdoors    =>  EXTERNAL  
Ground    =>  BOUNDARY = INPUT 1*TGROUND  
Zone      => ADJACENT = zonename  
Other Side Coefficients => BOUNDARY  

• Adjacent surfaces have to exist twice (once for each zone), but with different normals.  Despite ‘Type’ 
differences (floor/ceiling, wall/wall, etc), adjacent surfaces must have the same construction for proper 
syncing within TRNBuild.  

• Active slab surfaces should be divided in Trnsys3d (3 partitions for the active slab system are usually 
sufficient). To create divisions, simply draw a line.   

  
 
Note, the autosegmentation functionality within TRNBuild can’t be used to automatically divide the slab for 3D 
geometry.   

• Check for holes in surfaces! Surfaces with holes cannot be handled by TRNBuild and have to be split. 

• Windows are linked to its base surface and should not have more than four vertices. 

• Windows are usually drawn to the measurements of the window opening in the wall, including the size of the 
transparent glazing and the opaque frame. The frame is taken into account by setting a frame fraction and 
some properties in TRNBuild. Alternatively, you can model the window frame as a opaque surface and set the 
frame fraction of the window to FFRAME = 0. 
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• If you copy and paste surfaces make sure that the destination zone is active. You can copy surfaces from one 
Trnsys3d file into another, but sub-surfaces (windows) will not be recognized.  Review Trnsys3d surface 
entities by checking “Object info”. Windows can be copied in a second step onto the base surface. 

5.3 Troubleshooting 

• Use “Wireframe View” or “View Model in X-Ray Mode”  and the matching surface report option for 
checking if adjacent surfaces are mated and if the total number of the matched surfaces is equivalent to the 
available adjacent surfaces.  

• If a certain construction element is causing problems during the surface matching or importing procedure then 

these can be easily found in the “Search Surfaces”  option.    

 

• Type in the name of the surface or select an option by the active scroll-down menus. By clicking on 
“Search…” automatically all not-fitting elements will be hidden. Select “Unhide All” to show the whole model 
again. 

• Check the number of surfaces and sub-surfaces in each zone.  

• Check the boundary conditions of the model by “Render By Boundary Conditions” that highlights the 

geometry of a certain color syntax .  

 

• Always OPEN and SAVE the file within the Plug-in functionality. 

• Before closing the IDF file in Trnsys3d, save it and open it in another Sketchup file to check that everything 
works accordingly. 

• Before closing the IDF file in Trnsys3d, translate the IDF file into B18 and check if everything is translated and 
makes sense. 
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5.4 Trnsys3d zones 

• Give Trnsys3d zones “meaningful” names. No blanks are allowed!! 

• Trnsys3d zones have to be closed volumes, otherwise the volume calculation by the import in TRNBuild goes 
wrong. 

• To use the detailed interior radiation mode (shortwave and/or longwave radiation), the zones must be convex 
polyhedrons. 

Use the Outliner window (Window/Outliner) to view a list of all of your zone groups and shading groups. 
Groups can be selected by clicking items in the outline. Groups can be opened for editing by double-clicking 
items in the outline.  
 

 

• Use the command View > Component Edit > Hide Rest Of Model to hide all other groups (and the rest of the 
model) when you are editing a group.  When used with the Outliner, this command helps you get to zones 
that are buried in the core of a building.  
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5.5 Atrium and Virtual Surfaces 

In general, as in trnsys3d a building zone consists of one airnode. The simulation of zones with multiple airnodes 
is an advanced modelling feature. Large volumes like atria are often modelled by a stack of airnodes within one 
zone. Thereby the top airnode may have a higher temperature as the bottom airnode. The solar radiation entering 
a zone is distributed to all surfaces of all airnodes of that zone such that the radiation transmitted by the roof 
glazing of the top airnode may strike the floor surface of the bottom airnode. In addition, all surfaces of all 
airnodes of a zone are in longwave radiation exchange if the radiation mode longwave detailed is used (see 
\TRNSYS18\Documentation\05-MultizoneBuilding.pdf section 5.2.7.12). 

As Trnsys3d zones are restricted to one airnode, each airnode of the atrium should be defined as a separate 
Trnsys3d zone. The construction of the adjacent ‘surfaces’ between the Trnsys3d zones, which do NOT exist in 
the real world, should be assigned to ‘VirtualSurface’. Note that the surface type of the ‘VirtualSurface’ can be 
Floor, Ceiling and Wall only. 

‘VirtualSurfaces’ are not considered as heat transfer surface surfaces and are therefore not including in the 
thermal model after the import into TRNBuild. However, they are needed for ensuring that the Trnsys3d zones are 
closed volumes. (This is important for a correct volume calculation.) For enabling a correct export from TRNBuild 
to Trnsys3d the surface information is written in the geometry part of the *.b18 file. 

 

 

Within TRNbuild you can move air nodes from one zone into another (including the geometric information).  This 
way you can create radiative zones with multiple air nodes. For this, you right-click on the airnode name in the 
TRNBuild Navigator and select Move Active AirNode. 
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5.6 Importing Geometry from ifc-/dwg-Files to Trnsys3d 

It is possible to copy existing geometry from other files or file formats into a Trnsys3d idf, as long as the geometry 
is suited for the use in the TRNSYS building model:  

- Air volumes have to be closed. 
- Boundary surfaces of an air volume have to be presented by planar polygons without holes.  

Note: Windows must not be cut out of opaque surfaces 
- Boundary surfaces of an air volume should have no thickness (infinitesimally thin).  
- For considering thermal conditions of adjacent spaces automatically the boundary surface of both 

volumes must lie exactly on top of each but with reversed normal vectors (no distance). (see section 
Matching Surfaces) 

- Windows should be in separate “group” than the opaque surfaces. 

One example of geometry that can be used is ifc-exports that contain ifcSpaces. With the import function of 
SketchUp, the whole ifc model including the ifc spaces is imported.   
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• Open the “Show outliner window” of Trnsys3d plugin to see the imported data.   
If you are using ifc-Spaces, or you will find the zone(s) as grouped objects.  
 

 

• Copy the surfaces of a zone by highlighting one group and copy it using Ctrl+C or Edit > Copy. 

• Open another Sketchup window to use the Trnsys3d plugin.(This minimizes error messages and provides a 
better overview what’s already copied into zones) 

• Create a new Trnsys3d zone and assign a short name (no blanks).   
 

 

• Activate the zone by double clicking it in the outliner (a dotted grey line will outline the zone) 



Trnsys3d Tutorial 

34 

 

• Select Edit > Paste in place and the geometry is now part of the zone.  

 

Explode the copied zone by pressing right mouse button on the group and selecting “explode”.  
The color of surfaces will now change (grey: floor, beige: wall, dark red: ceiling).  
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• If the surfaces in the ifc file are triangulated like in the example above, they can simply be merged by deleting 
the edge that is dividing them. (Caution: this is possible for planar surfaces only)  
 

  

• If you have an ifc Model, where the Windows are just simple surfaces which lie in the same plane as the wall, 
you can use the ifcWindow Groups as they are to continue with the following steps. Switch to the other 
Sketchup with your imported model and “Copy” the window surfaces of the zone you just copied.  

• Switch to the Trnsys3d Sketchup window and check that the zone is still active (grey dotted outline). Then, 
select Edit > Paste in place, and the window elements are now windows related to the base surface of the 
zone. The windows should now be “visually cut out” of the wall. 

• Save in Trnsys3d by choosing Plugins > Trnsys3d > Save from the main menu. 

• Repeat this procedure for relevant zones.  
If many zones are going to be copied it is recommended to use the “save as” option for saving intermediate 
versions of the Trnsys3d files. For checking the *.idf file it might be useful to open it into a new SketchUp file 
instance with Trnsys3d and make sure that all elements appear correctly.  
In addition, it is recommended to split very large projects into pieces for reducing complexity and therewith 
susceptibility to errors. 

• For considering thermal conditions of adjacent spaces automatically the boundary surface of both volumes 
must lie exactly on top of each but with reversed normal vectors (no distance). (see section matching 
surfaces). Depending on your original geometry data there might be a distance or difference in size due to 
construction thickness. Currently, this needs to be adapted manually.  
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• When all zones are finished, adjust the boundaries and the adjacencies in each Trnsys3d zone, use “Object 
Info” to assign the Construction, Zone, Outside Boundary Condition and Outside Boundary object.  Adjust 
only the walls, ceilings, roofs, and floors. The integrated windows will adjust themselves.  
 

 

• Save the Trnsys3d file one final time and *.idf  file is now readable for TRNSYS 18 

• Import the *.idf file into TRNbuild and use the geometry viewer to visually check the created model. 
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5.7 Further Information  

Trnsys3d is based on the open-source legacy version of the OpenStudio plugin developed by the National 
Renewable Energy Laboratory for the United States Department of Energy. 

Therefore, the documentation of legacy version of the Open Studio plugin is included in the installation for further 
information. You can access it via Plugins > Trnsys3d > Further Information or you can find it in your SketchUp 
installation directory at .\Plugins\Trnsys3d\doc\help\index.html. The documentation includes an extensive 
reference guide as well as a large collection of tutorials.  

Be aware that not all features presented in the documentation are available in Trnsys3d. Features of OpenStudio 
which can’t be used in TRNSYS 18 are disabled or commented out. In addition, some features are modified in 
order to fit the needs of TRNSYS. OpenStudio itself can’t be used for TRNSYS 18 

Despite these differences the documentation is very helpful for working with Trnsys3d. 

 


