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Introduction
TRNSYS 18 Background
TRNSYS is a complete, modular, and expansible simulation environment for the transient simulation of thermal
systems including multi-zone buildings. It is used by engineers and researchers around the world to validate new
energy concepts, from simple solar domestic hot water systems to the design and simulation of buildings and their
equipment, including control strategies, occupant behavior, alternative energy systems (wind, solar, photovoltaic,
hydrogen systems), etc.
One of the key factors in TRNSYS’ success over the last 25 years is its open, modular structure. The source code
of the kernel as well as the component models is delivered to the users. This simplifies extending existing models
to make them fit the user’s specific needs.
The DLL-based architecture allows users and third-party developers to easily add custom component models,
using all common programming languages (C, C++, PASCAL, FORTRAN, etc.). In addition, TRNSYS can be
easily connected to many other applications, for pre- or post-processing or through interactive calls during the
simulation (e.g. Microsoft Excel, Matlab, COMIS, etc.). TRNSYS applications include:






Solar systems (solar thermal and PV)
Low energy buildings and HVAC systems with advanced design features (natural ventilation, slab
heating/cooling, double façade, etc.)
Renewable energy systems
Cogeneration, fuel cells
Anything that requires dynamic simulation!

Trnsys3d Plug-in
The new building model contains 3D geometric surface information that is required for the new detailed radiation
calculations. To easily input the geometric information into the building model, a plug-in called TRNSYS3d for
Goggle SketchUp™ has been developed. The Trnsys3d plug-in is based on the open source program
OpenStudio™ (http://sourceforge.net/projects/openstudio). Therefore, it can’t be included into the TRNSYS
package but is available for free download under GNU-GPL.
Note that the plug-in is not a full-featured interface. It will not help you create non-geometry data, such as
materials, controls, internal heat gains, HVAC equipment and systems, etc..
To use the plug-in as intended, you must have the energy model in mind (NOT the architectural model) from the
beginning as you create your SketchUp model. This means you should have your thermal zones defined before
you start.
New Developments
New features for the current Trnsys3d version 1.0.7.1 are listed below:




Simulation Studio Wizard for Trnsys3d
Zone templates (generic zone types) for Trnsys3d
Daylight Controls in Trnsys18
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Step 1: Create 3D model with Trnsys3d in SketchUp
Installation of SketchUp and Trnsys3d Plug-in







Download and install Google SketchUp from http://sketchup.google.com/.
Download and install Trnsys3d from www.trnsys.de/
Start Google Sketchup. If you are starting Google SketchUp for the first time, you will be prompted to
choose a Google SketchUp template. Choose the ‘Engineering – Meters’ template and click ‘Start using
SketchUp’.
If you already use SketchUp in IP units, it is recommended that you switch to ‘Engineering – Meters’
Template. To do this, go to Window>Preferences>Template> ‘Engineering – Meters’

Delete the drawing of the person standing at the axis origin by clicking on it and pressing ‘Delete’
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Understanding “Zones” – SketchUp Zones vs.Trnsys3d zones
SketchUp Zones

In SketchUp, the interior walls make up the zones. For example, in the building pictured above, there are no
interior walls so it is modeled as one large rectangular zone. Note that the smaller cube represents an exterior
shade and is not a zone.
Trnsys3d Zones (=AIRNODES)

Trnsys3d zones are different from SketchUp zones, particularly because Trnsys3d zones are used to simulate the
dynamic flow of energy. An energy model of a building should typically be separated into perimeter and core
zones. This is important to separate the effects of infiltration from the perimeter and core, and to correctly account
for solar gains into the building. In this tutorial, the example building is divided into two zones: the first floor with a
shade (see the purple box), and the second floor, without shading. It is also important to note that, unlike
SketchUp zones which can be any shape imaginable, Trnsys3d thermal zones must be convex, meaning that
every surface in the zone should be in the line of sight with all other surfaces of the zone.
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Build a single-zone model in Trnsys3d
Automatic Prompt to select pre-made zone template [new feature]
Upon launching Google SketchUp after the Trnsys3d plugin has been installed, you will be prompted to choose a
template for your 3D model. This template contains pre-defined information for your *.b18 file for schedules,
heating, cooling, ventilation, infiltration, internal gains and daylight. If you don’t want to use a predefined template,
choose NewFileTemplate.idf.
Choose German > 1_apartment_basedon_SIA2024.idf and click Open.
For the German library, these zone templates according to SIA 2024 are available:
1. Apartment
• Living/bedroom
• kitchen
2. hotel
• hotel room
• reception
3. office
• office
• office
• meeting
• reception
4. School
• classroom
• staffroom
• library
• lecturehall
• specialroom
5. Supermarket
• commercial
6. Restaurant
• restaurant
• kitchen
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Create a Trnsys3d Zone
Create a new Trnsys3d zone by choosing Plugins > Trnsys3d > New Zone Tool
from the main menu. A
small, blue cross-hair will appear at the tip of the cursor arrow. Hover over the axis origin until a small yellow dot
appears and click. This will place a blue box on the screen, which represents the Trnsys3d zone. If the blue box is
not visible, try changing the view to fit the object by going to Camera > Zoom Extents from the main SketchUp
menu. Now you can zoom in and out with the mouse wheel to fit the object in the window as desired.
SKY

NORTH

EAST
Note that by clicking on the screen outside of the blue box, the object
will disappear from view. This is normal. Turn on hidden geometry (Go
to View > Hidden Geometry from the main menu) and a small gray
cross‐hair will be visible at the opposite corner of the box.

This cross hair allows the user to find the Trnsys3d zone more easily. Note that if you click on the gray cross‐hair,
the Trnsys3d zone is outlined in blue again.
Double click on the small cross‐hair, which is now visible with hidden geometry turned on. The blue outline of the
Trnsys3d zone should be replaced with a slightly larger box with a broken, black outline. This ‘activates’ the
Trnsys3d zone. Note that in order to modify the Trnsys3d geometry the Trnsys3d zone MUST be ‘activated’
(outlined with the broken black line). Alternative to clicking on the crosshair, double click inside the blue box.

!
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This is what separates the Trnsys3d
geometry from SketchUp geometry.
Any object drawn in a ‘unactivated’
Trnsys3d zone is only SketchUp
geometry and will not be written out
to the Trnsys3d IDF file. It is VERY
important to make sure the zone is
activated before you start creating
geometry.
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Modifying Geometry within the Trnsys3d zone
Make sure that the Trnsys3d zone is still ‘active’ (outlined with the broken black line). Then create the floor for the
model by going to Draw ‐> Rectangle
from the main menu. Start the rectangle at the axis origin by clicking on
the origin. Next designate the size of the rectangle by typing ’12, 4’ and pressing enter (you can see the numbers
being input in the lower right hand corner of the screen, the comma between the numbers is operating system
language dependent and can also be ;,.). This will create a 12m by 4m floor.

!

Note the gray color of the floor. This color is automatically generated by
Trnsys3d and designates this surface as a floor in Trnsys3d. Similarly,
the walls and roof will be colored accordingly, in the next few steps.

Next ‘pull’ the rectangle up to create a rectangular prism. Make sure that the Trnsys3d zone is still ‘active’
(outlined with the broken black line). Choose Tools > Push/Pull from the main menu. Hover over the rectangle
until small blue dots appear on the floor surface and click ONCE with the mouse. The tool will ‘grab’ the rectangle
surface. Move the mouse up and down to see how the tool works. Move the mouse slightly up (so that the
rectangle is projecting towards the top of the screen), type ‘4’, and press enter. This will ‘pull’ the rectangle up to
create a 4m tall prism.
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!

Saving the IDF File
It is crucial to save the IDF file early and often. The IDF file is separate
from the SketchUp file and saving the SketchUp file will not preserve the
IDF information. To save the IDF file, choose Plugins > Trnsys3d > Save
from the main menu . If it is the first time you are saving the file a dialog
box will prompt you for a location and name

Creating fenestration objects
Trnsys3d can also be used to generate fenestration objects. Make sure that your Trnsys3d zone is still ‘active’
(outlined with the broken black line). Use the tape measure tool to create a 1m offset guides from the corner of
the wall. Select Tools > Tape Measure
and click once on the lower right hand corner. Hover to a point above
the corner, type in ‘1’ and press enter. A small black crosshair will appear. Using the tape measure tool again,
click once on the new crosshair and hover to a point left of it, type in ‘1’ and press enter. A dotted vertical guide
and another crosshair will now appear on the wall surface.

Now, select Draw > Rectangle and click once on the crosshair located on the wall surface. Type in ‘6,2’ and
press enter. Note that as long as the rectangle is completely contained within the wall surface, Trnsys3d will
recognize it as a window and automatically color it a transparent blue. A skylight is created the same way as a
window, but the rectangle is drawn on a roof instead of a wall. The guide lines can be removed by going to Edit >
Delete Guides. This will also remove the hidden geometry.
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Create external shading objects
Trnsys3d can be used to create shading objects, including overhangs and detached shading objects to represent
other buildings. Select Plugins > Trnsys3d > New Shading Group Tool , which is very similar to the new zone
tool. For this example, place the new shading group at the axis origin. Just like the new zone tool, in order to edit
the shading group geometry you must make the group ‘active’. To do this, press enter while the shading group
geometry is highlighted blue, or double click on the small gray cross‐hair that was created when you placed the
new shading group. When the shading group is ‘active’ you should see the rest of the model become lighter.

Use the rectangle tool to create the footprint of a detached shading object. Click the origin once and move the
mouse so that the footprint is previewed in the correct quadrant. Type in ‘4,4’, which will create a floor surface of
4m by 4m. Notice that the gray dotted box extends itself to include the floor surface.

Similar to creating a new zone, use the Push/Pull tool

to ‘pull’ the shading surface up to 4m.
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Using the Outliner Window
We will now use the outliner window to review the zones that we have created. To access the outliner window
from the main menu choose Window > Outliner :

You can use the outliner window to select the Trnsys3d objects by clicking on them. Double clicking on an object
in the outliner window will ‘activate’ the object. You should have one Trnsys3d shading group and one Trnsys3d
zone with a random six‐digit alphanumeric name. If you have any additional objects placed on accident select
them in the outliner window and delete them.
Using the Object Info Tool
Trnsys3d also has the ability to modify the Trnsys3d object information. Choose Plugins > Trnsys3d > Object Info
. The class type will change as objects are selected on the screen. If nothing is selected, the class type is
‘Building’. Change the name of the building to ‘TRNSYS18’

Click on the zone in the main SketchUp drawing area and you will see the class type change to ‘Zone’ in the
object info window. Change the Zone name from the default six digit alphanumeric zone name to ‘First_Floor’
- 13 -
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(!!!NOTE: No Spaces!!!) and press TAB on your keyboard to confirm. Select the Zone Type template
‘11livingbedroom’ from the drop-down for ‘Type’.

Open the outliner window again; notice that the Trnsys3d zone name has changed.

!

With the object info window still open double click on ‘First Floor’ in the
SketchUp model to ‘activate’ the zone. Notice how the object info
changes as you select a wall, roof, or window (note characteristics like
surface name, type, construction, zone, outside boundary conditions,
and the ground view factor). You can change the surface type, the
construction, and outside boundary condition for each surface. Toggle
between surfaces by clicking on them on the main SketchUp window.
You cannot change the surface name, as it will be automatically
changed later on.
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Movable shading for windows
Windows in TRNSYS 18 can have an automatic internal shading calculation depending to user-defined set points.
For this reason in the Object Info of Trnsys3d for windows there is a new drop down called shading device. Here
one can define if the window will have an internal or external shading device. The set points can later on be
adapted in the TRNBUILD window type manager.
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User-defined wall constructions
The option to define a new construction can be accessed through the SketchUp menu > Plugins > Trnsys3d >
New Construction. This allows defining user-specific names for constructions that can be afterwards selected by
the Object Info Window. The detailed wall construction including the layers and their thicknesses will have to be
done after the import in TRNBUILD.

User-defined Boundary Temperatures
The option to define a new boundary temperature control can be accessed through the SketchUp menu > Plugins
> Trnsys3d > New Boundary Temperature Control. This allows defining user-specific INPUT variables for a
boundary temperature that can be afterwards selected by the Object Info Window. Make sure to change the
Construction to ‘BND_WALL’, Outside Boundary Condition to ‘Other Side Coefficients’, and Outside Boundary
Object to ‘BOUNDARY=INPUT 1* CORRIDOR’.
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Add a second zone in Trnsys3d
Create the second floor of the example model by creating a new Trnsys3d zone and repeating the previous steps,
but ‘pull’ this floor to 5m instead of 4m. To create a sloped roof, portions of the rectangular prism will be ‘sliced’
off. Using the tape measure tool, place a crosshair guide 1m below the upper corner, as shown below. Then
select Draw > Line
and draw a line from the crosshair to the midpoint of the top edge. (The midpoint shows up
in blue when you hover over it.) Draw another line connecting the midpoint to the edge opposite of the one with
the crosshair, outlining the shape of the sloped roof.

Select Tools > Push/Pull, hover over a triangle until the blue dots appear and click once inside the triangle. Move
the mouse towards the other end of the prism until the cut follows through the entire length of the prism and click
to complete the ‘slicing’ (the cursor will snap to a triangle at the other end.) Repeat for the other triangle.

Note that the sloped roof you just created is now the same color as the walls. To re-assign the surface type in
Trnsys3d, right-click on the surface make the selections as shown below to finally choose ‘Roof’ for each sloped
surface. Repeat previous steps to rename this zone as “Second Floor”
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Finally, the interzonal adjacencies must be considered. The mating surfaces between the First Floor and Second
Floor must be linked together. Open Window > Outliner, and right click on the Second Floor to ‘Hide’ it. If View >
Hidden Geometry
is checked, then the second floor will appear hatched. You must uncheck it to hide it.

Next, double click the First Floor zone to ‘activate’ it. Right Click on the roof of the first zone and select Trnsys3d
> Object Info. Change the Type to “Ceiling” and construction to “ADJ_CEILING”. The outside boundary condition
should be “Zone” and the outside boundary object is “Second Floor.”

Right click on the Second Floor in the Outliner to unhide it. Repeat the same steps above to hide the First Floor
and reassign the floor of the Second Floor correctly. See the Object Info entries below. Note that although the
type of the Second floor is ‘Floor’, the construction must match the First Floor (ADJ_CEILING). This is critical for
adjacency recognition, when importing into TRNBUILD.
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Matching Surfaces
A method for automatic surfaces matching can be accessed through the SketchUp Trnsys3d menu toolbar. Click
on the surface matching icon
to start matching walls, roofs and floors. A window will pop up that gives you
different options like matching/unmatching surfaces or also to show the last reported matching information.

Depending on the size of the models and the select geometry for matching surfaces this can be a slow process.
Note that this method requires several key assumptions.
First, in order to match two surfaces the methods requires that they both have same number of vertices and that
the vertices exactly line up. This can most easily be accomplished using the snap functionality of the SketchUp
drawing tool.
Secondly, construction names of the matched surfaces will be changed to (for each corresponding surface or sub
surface type): "ADJ_CEILING" and "ADJ_WALL" if construction objects of those names appear in the current idf
file. If construction objects with the assumed names are not found, then the construction of the matched surface
will not be changed.

!

VirtualSurface Definition
Note that thermal stratification is normally modelled with a stack of several
zones. To model this example as an atrium, assign the construction as
‘VirtualSurface’. When it gets imported into the TRNSYS TRNBUILD, the
VirtualSurface will automatically be deleted and reflect an accurate radiative
model.
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Step 2: Import 3D geometry into Trnsys Simulation studio and TrnBuild
Import IDF File into Simulation Studio with the Wizard
The TRNSYS18 Simulation Studio offers the opportunity to automatically set up a simulation by importing the *.idf
file with the 3D-Building Wizard. After opening the Simulation Studio, select ‘New Project’ in the menu and the 3DBuilding Project Wizard can be chosen. The Wizard prompts you for the location of your *.idf file, the location of
the weather data file, (Note: The wizard requires a *.tm2 data format.) the building rotation, the static distribution
factor of solar direct radiation (typical range from 0.6-0.8), shading controls for exterior shades and boundary
temperatures of the ground and any adjacent spaces.
A great advantage of the 3D-Building Wizard is that all orientations of the Building are linked automatically. This
reduces errors and time used to link this information manually.

The main reason for importing the 3D geometry into Simulation Studio is to use the Studio Wizard to generate the
*.b18 and *.tpf files, which happens after you create the project with the Wizard. The*.dck is generated when you
click Calculate>Create Input File. It is also possible to import 3D geometry into TRNBuild, however this approach
only generates the *.b18 file and is only appropriate when you have an existing *.dck file. This alternative
workflow where the *.dck file is created from scratch, is not covered in this tutorial.
The inputs for the model in Simulation studio are populated with Information from the IDF template that was
selected during the launch of SketchUp.
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Select File > Save to save the Studio project.
The Wizard creates a 3D model with default settings which can be found under “Wizard Settings”. Double click
the Wizard Settings icon to see input variables. Double click each input variable to see default assignments. It is
possible, for example, to adjust the control for SHADE_CLOSE, directly in the circled cell below.
For ground-adjacent models, it is important to define ‘t_T_min’, as highlighted in the image to the right, below.
This variable equals the ‘coldest day’, in this example, 28 days from the start of the new year. Identify the coldest
day for your climate and adjust t_T_min as necessary.

For a first run, click Calculate > Run Simulation, which will launch Trnsys18 and by default it will run for a single
week. Trnsys18 will prompt you to “Exit the Online Plotter” upon completion of the simulation. Click “No” for the
purposes of this tutorial.
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By default there are 4 tabs along the bottom of the Online Plotter, showing outputs for solar radiation,
temperatures, heating and cooling power, and electricity consumption of interior loads. Hold down shift and hover
mouse in plotter area to see instantaneous values. User-defined outputs can be added, see next sections.
The directory where the Studio file is saved should now be populated with *.b18 and *.dck files.
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Step 3: Add data in TRNBuild
Open the *.b18 file generated by the Wizard in TRNBuild18 by right- clicking the Building icon and selecting ‘Edit
Building’. The inputs for the model in TRNBuild were populated when the 3D model was imported into Simulation
Studio, as described in the previous step.

Add a Comfort Point
Double click on Geo-Info in the TRNBuild Navigator. Select ‘gain, comfort points’ under ‘GeoPosition Geometry’
and click the green ‘+’ to add a comfort point. Adjust the coordinates if desired; typically 1m height is
recommended for comfort analysis. Click the Checkmark to close out of the Geo-Info dialogue and select File >
Save.
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Add an Output
Click ‘Outputs’ in the TRNBuild Navigator to access the outputs as seen from the Online Plotter. Click ‘+’ to add
an output

Select ‘First Floor’ from the list of “Available Thermal Airnodes” and click the LEFT arrow to add it to the list of
“Selected Thermal Airnodes”. Below, select NType number 9 ‘RELHUM’ from the list of “Available Outputs” and
click the LEFT arrow to add it to the list of “Selected Outputs”. Click the green checkmark box to exit the dialogue
and select File > Save.
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Step 4: Add data in Simulation Studio
Connect output to the printer
In Simulation Studio, right click the Building icon and click “Update Building Variable List”. This will make the new
output you recently defined in TRNBuild (NType 9 RELHUM) in the previous section, available to connect to a
printer.

Double click the dotted green line connecting the ‘Building’ icon with the ‘T_plotter’. Connect
‘RELHUM_First_Floor’ with ‘Left axis variable-4’. Click Ok to exit dialogue, and File > Save.
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Step 5: Modify 3D geometry with Trnsys3d in SketchUp
Export IDF file from TRNBuild
Right-click on the Building icon in Simulation Studio and select ‘Edit Building’ which will open the *.b18 file in
TrnBuild18. Select File > Export TRNSYS3d file…

You will be prompted to save your exported IDF file. Use a clear name to distinguish the exported IDF from the
original IDF, for example ‘Office_ModGeo.IDF’.

Open IDF file with Trnsys3d
Launch Google SketchUp. Navigate to ‘Office_ModGeo.IDF’ when prompted.
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Activate (double-click) the zone, make a change to the geometry (add a window as shown below), and save the
IDF file, using the same name ‘Office_ModGeo.IDF’
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Re-import IDF file in TRNBuild
Launch TRNBuild18. Select File > Import TRNSYS3d file. Browse to the location of the IDF file with modified
geometry, as described in the previous step: ‘Office_ModGeo.IDF’, select ‘Northern Hemisphere’ and click Import.

In Simulation Studio, double click the Building icon. On the External Files tab, Browse to the location of the *.b18
file with modified geometry that was generated from TRNBuild18: ‘Office_ModGeo.b18’

Select File > Save. Modified geometry is now incorporated in the model. You can double check by right clicking
the Building icon in Simulation Studio and selecting Edit Building, which will open the *.b18 file in TRNBuild where
you can search for the newly added window on the second floor.
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Step 6: Add daylight controls with TRNBuild [new feature]
Add daylight geometry point
This is a similar process to adding a comfort point. Double click on Geo-Info in the TRNBuild Navigator. Select
‘Daylight sensor points’ under ‘GeoPosition Geometry’ and click the green ‘+’ to add a daylight sensor point.
Adjust the coordinates if desired; typically 1m height is recommended for daylight sensing. Click the Checkmark
to close out of the Geo-Info dialogue and select File > Save.

To view/modify the settings for daylight controls that were pre-defined as part of the Trnsys3d template when
starting the model in SketchUp, or to create your own daylight control, expand the ‘Daylight Control Types’ from
the TRNBuild Navigator. Double click ‘11_livingbedroom’. Select ‘daylight sensor position’ and choose the
GeoPosition that was created in the previous step. Close out of this window by click the green check box.
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Click “Zone: First_Floor” in the TRNBuild Navigator, which will open the zone properties window. Click the Gains
icon and select ‘Ltg_11livingbedroom’ to access the ‘lights’ gaintype category properties. Select a daylight control
that has been pre-defined as part of the Trnsys3d template when starting the model in SketchUp, for example,
‘11_livingbedroom’.

Add illuminance and daylight control signal as outputs
Click ‘Outputs’ on the TRNBuild Navigator and click the green ‘+’ icon to add new outputs. Add outputs NType
168 and 171, the Daylight shading control signal and Daylight illuminance of first daylight controlled gain. Note
that multiple daylight control gains can be defined, each with its own GeoPosition. Select File > Save.
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Expand “Windows” on the TRNBuild Navigator. Double click ‘EXT_WINDOW1’ to access the Window Type
Manager. Under Daylight Properties, type in ‘glass_77’ for ‘Material name unshaded’ and ‘glass_30’ for ‘Material
name shaded’, to define the material of the window system when it is unshaded and shaded, respectively. For
more materials, click the ‘Open radiance material file’ button, and use the automatically opened text file to browse
materials and make new ones. Refer to Section XX in the Trnsys18 Documentation for further information.
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Select Tools > Generate radiance files. Choose “classic” format of daylight coefficients for DAYSIM. Adapt the
geographical information according to your weather file.
Refer to Section XX in the Trnsys18 Documentation for further information regarding pre-processing for daylight
simulation. Click the Green triangle button to generate the radiance files. This may take a few minutes for a
simple model, to a few hours for complex models.
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Connect to plotter in simulation studio
In Simulation Studio, right click the Building icon and click “Update Building Variable List”. This will make the new
DLC outputs you recently defined in TRNBuild (NType 168 and 171) in the previous step, available to connect to
a printer.

Double click the dotted green line connecting the ‘Building’ icon with the ‘T_plotter’. Connect
‘DLSHAD_First_Floor’ with ‘Left axis variable-5’. Connect ‘ILLUMDLC1_First_Floor’ with ‘Left axis variable-6’.
Click Ok to exit dialogue, and File > Save.
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Step 7: Add BSDF Window model in TRNBuild
See separate tutorial BSDF_Tutorial.pdf
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Simulation and Results
Run the model in simulation studio by selecting Calculate > Run Simulation.
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